Author Topic: Too much bass in Fraps recordings  (Read 4289 times)

ふねん1

  • Scientific editor
  • If you're alive, you can always keep moving.
Too much bass in Fraps recordings
« on: October 02, 2015, 05:45:53 PM »
So I'm getting back to recording Touhou videos with Fraps, but all of a sudden the recordings seems to have really jacked up bass, which is distorting the sound quite noticeably. I'm using Windows 8.1 with an IDT High Definition Audio CODEC. The sound plays just fine when running the games themselves - this only shows up after recording them. I suspect that there's some setting, or perhaps some recording feedback somewhere, that's boosting the bass during the recording process itself, but I have no idea what it would be or where to search for it. When I right-click the speaker icon on my desktop and select Recording Devices, Stereo Mix is the only device that's active. From my online searches, I've seen people suggest going to the Enhancements tab under Properties to turn off Bass Boost and such, but that tab is nowhere to be found (for reference, it's not available for Playback Devices either). I've experimented with Stereo Mix's Levels tab and the audio quality under Advanced, but neither of those made any difference. Anyone know where else I might find something to lower the bass during recordings? Or if I should really be using a different sound card/recording program altogether lol.
"Science is more than a body of knowledge. It's a way of thinking." - Carl Sagan

NEW AND IMPROVED YOUTUBE, now with 60 fps Touhou videos! Latest video update: WBaWC Lunatic/Extra no-miss no-bomb no-Roars no-Spirit-Strikes compilation.

Uruwi

  • Nightmare of Torrential Precipitation
  • 478 million goober
Re: Too much bass in Fraps recordings
« Reply #1 on: October 02, 2015, 06:11:25 PM »
You'll have to edit the audio. FFT the waveform, and adjust the low frequencies.
foo = foldl $ flip ($)
Highest difficulty 1CCed for each game, by shot type in the original order. (-: never 1CCed on any difficulty, or never used; E: easy, N: normal, H: hard, L / U: lunatic / unreal.)
EoSD [NNNE] PCB [EE--N-] IN [NEEE + Ex Border] PoFV [Mystia N, Mystia E no charge] MoF [EN--H- + Ex Marisa B] SA [N-----] UFO [----EN] TD [NENE] DDC [EE-EHE + Ex Marisa B & Sakuya A] LoLK [PD --N- Legacy ---N] EE [N- + Ex Yabusame] EMS [N-- + Ex Yabusame] RMI [NHN + Ex YaoSuku]
Avelantis (demo) Easy YuukiB 426,077,200

ふねん1

  • Scientific editor
  • If you're alive, you can always keep moving.
Re: Too much bass in Fraps recordings
« Reply #2 on: October 02, 2015, 07:13:15 PM »
So basically extract the audio and edit it in something like Audacity? I'm familiar with the AoA audio extractor at least, though other suggestions would certainly help. As for putting them back together, would VirtualDub (or even Movie Maker) do the trick?
"Science is more than a body of knowledge. It's a way of thinking." - Carl Sagan

NEW AND IMPROVED YOUTUBE, now with 60 fps Touhou videos! Latest video update: WBaWC Lunatic/Extra no-miss no-bomb no-Roars no-Spirit-Strikes compilation.

Re: Too much bass in Fraps recordings
« Reply #3 on: October 02, 2015, 11:01:40 PM »
You'll have to edit the audio. FFT the waveform, and adjust the low frequencies.

That's a band-aid fix, and you can easily ruin the quality of the audio by using an equalizer without understanding how to use one and how harmonics work. Plus he mentioned that the recording itself sounds distorted. No amount of post processing can fix that.

OP, your audio card records audio digitally. Using the right settings, any digital audio source, such as the audio output from a game, can be captured by any audio card without alterations, assuming the audio card is set to use the same or higher sample rate than what you're trying to record. It sounds like your audio card has some sort of bass boost activated, which is being recorded along with your gameplay. When you watch the recording, you're hearing the bass boost twice. If possible, please post a recording of you playing, along with a recording of any track from the music room of the game you're trying to record (it's ok if they're 2 separate recordings). I can analyze the audio and I may be able to give you a better idea of what's going on.

Some more info about your hardware and settings would be nice too. Are you using a prebuilt computer? What's your motherboard? What's your sample rate set to? Are you sure you have the latest drivers for your audio card installed, and if so where did you find them? What's your music and SFX volume set to in-game? Is fraps set to record any audio input? Try disabling that.

If you're looking to replace that audio card, don't google for "audio card", you'll only get junk looking for that. Look for USB audio interface. Compared to on-board audio, audio interfaces give you more control over the audio, along with having higher audio quality (specially noticeable if you already have decent headphones or speakers) and lower audio latency. As for alternative recording programs, you can try OBS. It's way better than fraps for most people.
« Last Edit: October 07, 2015, 05:59:21 AM by Romantique Tp »

ふねん1

  • Scientific editor
  • If you're alive, you can always keep moving.
Re: Too much bass in Fraps recordings
« Reply #4 on: October 03, 2015, 12:40:18 AM »
Here's a recording, showing part of a replay of MoF Stage 1 followed by part of Romantic Fall being played in the Music Room. For this recording I had the in-game volume set to 70% for BGM and 50% for SE, which is lower than what I normally use (100% and 80%), but I wanted to see if it made any sort of difference (not much apparently). The audio sample rate of the recording was 192 kHz - I didn't do any processing on the video after recording, and I didn't have "Record external input" checked in Fraps.

My computer is an HP Pavilion 500, with an HP 2AF7 motherboard. I actually ran an update on my driver this morning, through the Properties buttons for Stereo Mix (under Sound in Control Panel) and then under Controller Information, though according to the driver dates it was only bumped up from June 2013 to November 2013. I don't expect that this changed anything, as I was having the bass boosting problem yesterday too. And yes, the bass being boosted twice is what I was getting at in the OP, but not finding any menus or options anywhere that might lead me to a place where I can change this is what's puzzling me the most.
"Science is more than a body of knowledge. It's a way of thinking." - Carl Sagan

NEW AND IMPROVED YOUTUBE, now with 60 fps Touhou videos! Latest video update: WBaWC Lunatic/Extra no-miss no-bomb no-Roars no-Spirit-Strikes compilation.

Re: Too much bass in Fraps recordings
« Reply #5 on: October 03, 2015, 05:47:38 AM »
This does sound like I would expect from a generic sound card bass boost. I'm not hearing distortion, is it still there when you watch your video?

Doing some quick research, that mobo should be equipped with a IDT 92HD65C, which is supposed to have its own control panel like most audio devices: http://www.mouser.com/catalog/specsheets/Tempo_92HD65C-DS-1-1.pdf
The driver you got from Microsoft is most likely a generic driver with only basic functions. You'll probably find the proper driver with the control panel on HP's site: http://support.hp.com/us-en/drivers

If you can't find the audio driver, install the chipset driver from the site. Restart your computer after installing everything and the options you're looking for should show up.

Also note that your sample rate doesn't need to be that high. High sample rates improve the quality of synthesizer filters and effects, and higher bit depth lowers the noise floor, which is already barely audible at 16 bit, and that's pretty much it. Unless you make music, you don't need more than 48000 Hz @ 24 bit. Any higher is just wasting CPU cycles.

ふねん1

  • Scientific editor
  • If you're alive, you can always keep moving.
Re: Too much bass in Fraps recordings
« Reply #6 on: October 03, 2015, 06:57:09 PM »
Well, I see multiple options under Driver-Audio: two IDT HD audio drivers and two Realtek HD audio drivers. Hopefully this link should work on other people's ends too, so you can see what comes up for my system. Are there any significant differences between the versions listed? And if you recommend I change from IDT to something else, is Realtek any good? I'm not very knowledgeable on the various drivers.
"Science is more than a body of knowledge. It's a way of thinking." - Carl Sagan

NEW AND IMPROVED YOUTUBE, now with 60 fps Touhou videos! Latest video update: WBaWC Lunatic/Extra no-miss no-bomb no-Roars no-Spirit-Strikes compilation.

Re: Too much bass in Fraps recordings
« Reply #7 on: October 03, 2015, 07:13:31 PM »
You're using an IDT card, so you should get the IDT driver. Installing the Realtek driver will probably not stop your PC from booting but it's very unlikely to actually work. Download the most recent IDT driver you see there. For me it's this one: http://i.imgur.com/eVJP6ZX.png
« Last Edit: October 07, 2015, 05:59:29 AM by Romantique Tp »

ふねん1

  • Scientific editor
  • If you're alive, you can always keep moving.
Re: Too much bass in Fraps recordings
« Reply #8 on: October 03, 2015, 08:21:18 PM »
So after installing the driver I noticed a new link in the Control Panel under Hardware and Sound, one for a "DTS Audio Control Panel". Not entirely sure if it's related to IDT because of the slightly different name lol, but I did find an "audio enhancement" section in there. I unchecked the box, and now the sound in my videos isn't being boosted, so it looks like problem solved. Thank you so much for the help. ^.^ b
"Science is more than a body of knowledge. It's a way of thinking." - Carl Sagan

NEW AND IMPROVED YOUTUBE, now with 60 fps Touhou videos! Latest video update: WBaWC Lunatic/Extra no-miss no-bomb no-Roars no-Spirit-Strikes compilation.

Re: Too much bass in Fraps recordings
« Reply #9 on: October 05, 2015, 01:59:31 AM »
So after installing the driver I noticed a new link in the Control Panel under Hardware and Sound, one for a "DTS Audio Control Panel". Not entirely sure if it's related to IDT because of the slightly different name lol, but I did find an "audio enhancement" section in there. I unchecked the box, and now the sound in my videos isn't being boosted, so it looks like problem solved. Thank you so much for the help. ^.^ b
Ahahaha. The IDT enhancements boosted the bass, the FRAPS recording captured the boosted bass, and then the IDT enhancements boosted the bass of the recording, creating double-boosted bass.
This is one of the reasons why audio enhancements should almost always be disabled imo.
Playing Touhou since 18 March 2012. Playing video games since 19XX.
Normal 1CC: EoSD, PCB, IN, PoFV, MoF, SA, UFO, TD, DDC, HSiFS, CtC.
Extra 1CC: EoSD, PCB+Phantasm, IN, PoFV (K&S), MoF, SA, TD, HSiFS, CtC+Phantasm.
Hard 1CC: EoSD, PCB, IN, MoF, TD, CtC.
Lunatic 1CC: EoSD